logo
IRC Archive / Freenode / #debian / 2010 / February / 19 / 9
jelly-home
!ops MarkovBot doing channel msgs
dpkg
Hydroxide, bob2, caphuso, dondelelcaro, doogie, eeyore-, ElectricElf, ):, helix, ljlane, LoRez, RichiH, mentor, Netsnipe, TML, walters, xk, abrotman, gravity, azeem, Maulkin, stew, peterS, Alife, Myon, Ganneff, Maulkin, weasel, zobel, themill: jelly-home complains about: MarkovBot doing channel msgs
SolarisBoy
and i would hope you use the option to continue broken xfers too with rsync....
leejongwook
:)
(Action) nice ---> <a rel="nofollow" href="http://www.debianadmin.com/howto-use-downloaded-isos-as-a-repository-in-debian.html">http://www.debianadmin.com/howto-use-downloaded-isos-as-a-repository-in-debian.html</a>
jelly-home
thanks, unnamed op
leejongwook
no need internet :P no need many CDs or DVDs, all i need ls ISOs. now i could go to desert island with my pc :P
LordVorp
so, with a "blank" system, what's the package to install from apt-get that will bring in a complete desktop? (kde or gnome)
jelly-home
!tell LordVorp about install kde
!tell LordVorp about install gnome
LordVorp
jelly-home++ # w00t. I love IRC...
jelly-home
LordVorp: also, /msg dpkg tasksel
abrotman
.yes
...yes
jelly-home
no!
abrotman
...yes.
Titan8990_
maybe
abrotman
uh ...
jelly-home
three
abrotman: well it is quieted now
abrotman
...hiya.
MarkovBot: who owns you
screw it
jelly-home
abrotman: you did notice the +q above, right?
abrotman
nope
oh .. it's gone now
AbsoluteBeginner
hi! how can I install a special (not current) version os a package ?
jwaters
need to have a test server mimic one in production, it debian 4.0, when I try to do a fresh install with netinstall cd it fails stops running when it goes out to the mirrors
AbsoluteBeginner
a previous version of a current package
jwaters
is there a mirror that has 4.0 still on it for fress installs
xyan
!tell jwaters about debian archive
Titan8990_
jwaters, if you have a system backup, just restore it
LinuxGuy2009
Can someone verify if Cheese webcam recorder in Debian testing branch has support for changing the resolution of the capture? The one in stable does not and I am considering moving to testing so that I can have this feature. I just got a new webcam and want to make Debian tutorials for YouTube with it.
jwaters
Titan8990, that require downtime, which is not a luxury
Titan8990, is a good option and see if i can get it
xyan, thanks for info, doesn't look like they have etch in there
AbsoluteBeginner
has someone a hint for me how I can install a previous version of a current debian package ?
xyan
jwaters: oh right the mirrors have "oldstable" for the previous release though http://ftp.debian.org/debian/dists/
jwaters
xyan, then the site must be getting hammered, really slow download
Titan8990_
LinuxGuy2009, often you will not need to upgrade to a new release for a single package (especially desktop applications)
LinuxGuy2009, im sure you can find a changelog somewhere
!tell LinuxGuy2009 about ssb
judd, versions cheese
judd
cheese -- lenny: 2.22.3-3; sid: 2.28.1-1; squeeze: 2.28.1-1
al_
rettub: deadcats command stopped working after a while....what was your xargs solution?
LinuxGuy2009
Yeah I dont see a backport on packages.debian.org
Titan8990_
LinuxGuy2009, i don't think backports show up on there. backports has its own packages.domain.org
Failrar
single side band?! :P
LinuxGuy2009
I just need an app to record video and select the resolution. 1280x1024 native on the camera is laggy.
rettub
al_: sorry I've no history yet, swtched the box but use find ... |xargs rm
Titan8990_
LinuxGuy2009, but judd would know. have a look at pm from dpkg about ssb
rettub
al_: try it first with find ... |xargs ls -l
peterrooney
AbsoluteBeginner: here be dragons, but... get previous .deb, then dpkg --force<forceoptions>-i <name_of_deb> # WARNING: may-break-system
SimManiac
hi
LinuxGuy2009
!tell LinuxGuy2009 about ssb
AbsoluteBeginner
peterrooney: where can I download previous versions ?
LinuxGuy2009
Well thats no help at all.
abrotman
!tell LinuxGuy2009 about selftell
LinuxGuy2009
LMFAO no helping myself. Ok sure thats a good idea.
abrotman
LinuxGuy2009: the ssb would be a help if you felt like backporting cheese and who knows what other dependencies that might allow it to do such a thing
LinuxGuy2009: and your question may also be device dependent
there is a *very* small #cheese on irc.gnome.org
LinuxGuy2009
I have no idea what ssb is. That dpkg message cuts off. So I didnt see anything about ssb in it.
al_
i recall there was some prob i read with using xargs with lots of files
peterrooney
AbsoluteBeginner: packages.debian.org goes back as far as etch
abrotman
it got cut off where? the first sentence?
works fine here
LinuxGuy2009
!tell LinuxGuy2009 about ssb
abrotman
!tell LinuxGuy2009 about selftell
leejongwook
[Q] i can't find local download site for Debian-DVDs @_@
LinuxGuy2009
abrotman: I cant very well look at the fu*king message without doing that now can I?
wols
define "local"
LordVorp
ok so I've just installed KDE in my new Lenny install, and I'm looking at options, and under Fonts->antialiasing, it says "Use system settings", and when I Enable it the LCD opts are greyed out ... anybody know where the "system settings" for fonts are?
abrotman
LinuxGuy2009: READ
wols
LinuxGuy2009: you can /msg dpkg <stuff>
abrotman
LinuxGuy2009: the bot also tells you to "/msg dpkg foo" .. you have a *serious* reading/google/research issue
LinuxGuy2009
You can kiss my ass!
abrotman
LinuxGuy2009: now please read what the bot has sent you, and apply it
LordVorp
abrotman: u forgot to kick him. :)
AbsoluteBeginner
Thx peterrooney for your help !
russian_ulysses
have problems with azureus 2.5.0 after upgrade to squeeze -- can't upload, telling me 'Network is unreachable'. Azureus worked fine under Lenny. Transmission works fine under both Lenny and Squeeze. How can I fix Azureus, I prefer it over Transmission?
rettub
for Realtek PHY RTL8201EL / 8201CL can I use the module '8139too + RealTek RTL-8129/8130/8139 PCI Fast Ethernet Adapter support' - anyone knows?
Hyperzid
Whats latest lenny kernel?
Titan8990_
Hyperzid, 2.6.26, same as its been since release
votyakf
2.6.30-bpo.1 - backport:))
Hyperzid
Titan8990, so 2.6.26-2-686 is the latest?
Titan8990_
hyperutz, -17 if thats what your looking for
simonrvn
!ops WaH-ShE on-join spam
dpkg
Hydroxide, bob2, caphuso, dondelelcaro, doogie, eeyore-, ElectricElf, ):, helix, ljlane, LoRez, RichiH, mentor, Netsnipe, TML, walters, xk, abrotman, gravity, azeem, Maulkin, stew, peterS, Alife, Myon, Ganneff, Maulkin, weasel, zobel, themill: simonrvn complains about: WaH-ShE on-join spam
[Jasper]
hej guys, anyone knows where autofs logs too?
KB1JWQ
WaH-ShE: Please stop that. :-)
Titan8990_
Hyperzid, its the latest and only official version
Hyperzid, backports is semi-official and same to use however
simonrvn
thanks
Hyperzid
Titan8990, why isnt it upgraded?.. its vulnarable to a local root exploit.
Titan8990_
Hyperzid, no, it gets security patches, just no new features
Hyperzid, if you are really concerned, you can subscribe to the debian kernel and security mailing lists like i do
Hyperzid
Titan8990, I have 2.6.26-2-686.. and my box is vuln.
Titan8990, if thats the latest.. why do I get root from a local user account then?
Titan8990_
Hyperzid, if you are talking about the two recent null pointer dereference vulns, they are both patched on that kernel
Hyperzid, you were able to exploit the kernel to gain privledge escalation?
Hyperzid
Titan8990, i'm talking about the sock_sendpage
Titan8990, yes!
zobel
dondelelcaro: i get highlighted here even though i have no chanserv rights here. can you fix that (either way).
Hyperzid
http://www.dotcom5.net/article/Linux/177.htm
Titan8990, ah.. its the null pointer dereference vulns
Titan8990, do you know which patch thats patched?
simonrvn
zobel: foactoid =~ s,foo,bar,
zobel: factoid =~ s,foo,bar, even
Hyperzid
Titan8990, where do I subsribe to those mailing lists?
Titan8990_
!lists
Hydroxide
simonrvn: does that work for !ops <blah> ?
simonrvn: intuitively seems like a special case, but I haven't tested
simonrvn
zobel: e.g. cmd: ops (.*?) =~ s,foo,bar,
Hydroxide: ^^ ;)
Hydroxide
ok :)
zobel
i am not sure if that works for ops
i thought that fact is locked.
simonrvn
if it's not locked, yes it will
Hydroxide
simonrvn: for some reason I'm at the beginning of the ops output on both freenode and here ... I have no idea why - I certainly wasn't the first #debian chanop. doesn't bother me but still is surprising
Hydroxide, mmap: Operation not permitted is what i got when i tried to run the exploit code and unpriv user
Hydroxide
Titan8990_: wrong h name
Hyperzid
Titan8990, so what do I need to install to not be vuln anymore?
simonrvn
Hydroxide: i'd say alphabetical order but it isn't really sorted *shrug*
zobel
simonrvn: i have no problem being chanop here, just having the rights would help.
Titan8990_
Hydroxide, sorry
Hydroxide
Titan8990_: you meant Hyperzid I assume
simonrvn
zobel: i'm with ya there ;)
Titan8990_
Hyperzid, just update your system, the lastest revision should be -17
[Jasper]
my mtab keeps reporting: automount(pid2701) /var/autofs/backupdir autofs rw,fd=4,pgrp=2701,minproto=2,maxproto=4 0 0
but this isn't mounted...is there any way to refresh mtab?
Hyperzid
Titan8990, apt-cache search linux-image-2.6.26-17 <-- dosnt return anything.
simonrvn
zobel: i used to be here. i've asked to be again, mostly because i keep odd hours and most of them if not all of them aren't here when one is needed at those odd hours.
Hyperzid
Titan8990, and when I do: apt-get dist-upgrade .. I dont get any kernel updates
Titan8990, i've also done apt-get update before all this.
karme
!security
dpkg
Put "deb http://security.debian.org lenny/updates main contrib non-free" in your /etc/apt/sources.list file to keep up-to-date on security updates in stable. Run "aptitude update" and "aptitude upgrade" (or "aptitude full-upgrade" if the updates are kept back). Also ask me about <oldstable security>, <testing security>, <unstable security>.
wols
,versions linux-image-2.6-486
judd
linux-image-2.6-486 -- etch: 2.6.18+6etch3; etch-security: 2.6.18+6etch3; etch-backports: 2.6.26+17~bpo40+2; lenny: 2.6.26+17+lenny1; lenny-backports: 2.6.30+20~bpo50+1; sid: 2.6.32+23; squeeze: 2.6.32+23
[Jasper]
how can this be: dl-clu01:/var/autofs/backupdir# umount /var/autofs/backupdir
umount: /var/autofs/backupdir: device is busy
Titan8990_
Hyperzid, thats not a remote vulnerability.... thats local priv escalation
[Jasper]
autofs has been stopped?
wols
[Jasper]: some program has a file open on this mount
Hyperzid
Titan8990, exactly what I was saying.. "local root exploit"
[Jasper]
wols how can I find out what program?
wols
[Jasper]: lsof fuser
Hideme
Is there a way to limit the use of a php script (form mailer) to a specific domain with apache?
Titan8990_
Hyperzid, actually it appears i might have manually done something with this vuln in accordance with the mailing list
[Jasper]
hmm never used that before wols
Titan8990_
Hyperzid, try: `cat 'vm.mmap_min_addr = 4096' > /etc/sysctl.d/mmap_min_addr.conf` and then try to run the exploit code again
[Jasper]
wols how does that work ? should I jus tgrep on backupdir?
karme
Hideme: yes, you can limited based on source host, but probably it is better to use a real authentication mechanism
~s/limited/limit
Hyperzid
wols, Titan8990 I have "deb http://security.debian.org/ lenny/updates main non-free contrib" in my /etc/apt/sources.list..and still latest kernel I have installed is 2.6.27-2
sorry 2.6.26-2-686
Titan8990_
hyperutz, apt-cache policy linux-image-2.6.26-2-686
simonrvn
er, you mean echo, right ? ;)
Titan8990_
simonrvn, oh... right :)
simonrvn
:)
Hyperzid
*** 2.6.26-21lenny3 0 500 http://security.debian.org lenny/updates/main Packages 100 /var/lib/dpkg/status 2.6.26-21 0 500 http://ftp.no.debian.org lenny/main Packages
[Jasper]
wols? dl-clu01:/var/autofs# fuser -m /var/autofs/backupdir ----------- /var/autofs/backupdir: 2701
n1c0
hi
if i install a package which have already be installed as a dep, apt set the pakage manually installed, how to unset that ?
marsje
Someone installed a very basic debian server using a swueeze netinstall cd. Is there an easy way to install common server packages, like sudo?
I mean all at once...
simonrvn
use aptitude's ui?
or specify more packages on the command line? your choise.
hjb
hi togehter. anyone has a quick tip how to convert a directory of .flac to mp3?
simonrvn
choice*
hjb
i've tried rhytmbox but it doesn't provide anything for this
simonrvn
script something with mencoder maybe ...
NiLon
try lame
Hyperzid
Titan8990, whats wrong with my apt-get policy?
marsje
simonrvn: I know at install time you can chose like a set of packages, like basic, mail, file-server... Can I do it with aptitude?
hjb
NiLon: can i use lame without sripting anythind? I'm in a rush
simonrvn
that's tasksel, not aptitude
NiLon
hjb well uh, ofc you need
marsje
simonrvn: looks like it :)
hjb
NiLon: huh? i don't get it :-) what's ofc?
NiLon
hjb nothing..
hjb
NiLon: Warning: unsupported audio format
NiLon: lame seems to doesn't like flac input
NiLon
hjb intresting, it should
atleast I have converted with it
hjb
NiLon: i'll try with for file in *.flac; do $(flac -cd "$file" | lame -h - "${file%.flac}.mp3"); done
NiLon
you got lame3 or older?
hjb
NiLon: no idea, just done aptitude install lame
NiLon
then it's not lame3
hjb
btw. that command i've posted seems to work
NiLon: it's the older one?
NiLon
it's 1.x or 2.x
3 is not in repo afaik
hjb
NiLon: ok, that would explain why it worked for you, but not for me ;)
NiLon
mp3 is patended so..
hjb
NiLon: thats the problem
dec3pti0n
is it possible to debootstrap ubuntu lucid on a lenny box ?
NiLon
hjb oggdec foo.flac ;)