logo
IRC Archive / Freenode / #opensolaris / 2009 / December / 09 / 4
nachox
jumpers in a pci card?
Sp0tter
Norrin: yes
[lewellyn]
worst i've done is pfexec ksh93 -l
Sp0tter
Norrin: the drives show up fine in the card bios
Sp0tter
yea I know
all drives show up fine on boot
[lewellyn]
gah. docs.sun.com is useless today :(
it's telling me to do what i've already done
Norrin
Sp0tter: is there settings on the bios that can / need to be set?
Sp0tter
no
Norrin
Sp0tter: you have to use format first before zpool right?
format and / or fdisk
nachox
no
this has nothing to do with format
solaris doesnt actually see any disk attached to that sata controller
Norrin
ok. thought it did.. he said zpool told him the disk wasn't ready
Sp0tter
there is already a zpool created with these disks
the issue is the controller
and opensoalris interfacing with the disk trhough it
so with my other controller i had to flash the rom so it was just a disk controller and get rid of the raid featuers, but witht his one, it already has the "non raid" setting built in
and is already at latest bios revision
Norrin
hmm. hopefully that means my card won't have that problem lol
Sp0tter
i'm glad we can make you feel good
[lewellyn]
http://nopaste.info/f8c5ccacab.html in case there are any kind souls who have good karma with the nfs gods right now
nachox
[lewellyn], just use cifs :P
[lewellyn]
nachox: cifs in 111b has issues
and can i use autofs with cifs?
nachox
openafs?
[lewellyn]
the goal here isn't to add MORE infrastructure :P
nfs works fine from other boxes, as i've said. that's the most annoying bit
lblume
Good morning people.
nachox
[lewellyn], http://docs.sun.com/app/docs/doc/820-2429/automountsharetask?a=view
[lewellyn], is it a known bug with b128 and hyper-v?
[lewellyn]
nachox: gdamore said there was a change in 129 to dnet
something to do with microsoft virtualization
ok. looking at your link, how do i tell it which user to mount as?
nachox
[lewellyn], ah, then wait :P much easier
[lewellyn]
can't wait. i've delayed them a week and a half already. and it was supposed to be live yesterday :P
nachox
you're actually considering using cifs? i was joking
[lewellyn]
i'm considering anything which will get this into a functional state at this moment
that page you linked to is somewhat confusing. does it only accept unix UIDs?
and are ACLs honored?
Sp0tter
i just reflash ones
to see if it made any difference, it didn't, its already the newest bios
[lewellyn]
i don't see why one would need dirperms if it's using the correct authentication
and i don't get how persistent passwords would work across boots
nachox
[lewellyn], the cifs client in solaris is ackward, permissions and the suck are odd, you might want to read it's man page
[lewellyn]
(nor with domains)
i'm thinking i'm skipping cifs
(Action) goes back to trying to decipher the data in wireshark
i really don't want to have to use a few hundred gigs on the host running hyper-v :P
nachox
[lewellyn], cant microsoft virtual machine emulate a different nic?
[lewellyn]
(Action) files a bug: "'Permission denied' is too vague of an error message from NFS"
nachox: yes. but opensolaris doesn't see it
nachox
you're stuck with a fast ethernet card? no gb ethernet card can be emulated?
[lewellyn]
pci bus 0x0000 cardnum 0x08 function 0x00: vendor 0x1414 device 0x5353
Microsoft Corporation Device unknown
i think that's it
nachox
uncool
flyingparchment
in a normal VM, network card supposed speed has nothing to do with actual throughput
you could get 1GE speeds from an emulated 10BT card
maybe hyper-v artifically limits it, but that would seem odd.
[lewellyn]
oh that's the video card
flyingparchment: yeah. there's a bottleneck due to dec 21140 being less efficient than their own network card
but it shouldn't matter
not like i'll need more than 3-4mbit/s anyhow
the problem is that i'm not able to mount nfs, not that i can't use the network :P
i'm not terribly keen on running dev in hyper-v anyhow
http://nopaste.info/89dd49606e_nl.html if the scanpci actually interests anyone
ranks
I have a question about dedupe in snv_128a: If I copy the contents of one directory to another on the same zfs filesystem with dedupe, I notice that the zpool usage doesn't go up, and the dedupe percentage goes up. This is expected. zfs list, and df, though show increased usage. My question is ... What good is dedupe, if you cant use the space its saving. I'm sure I'm just not understanding things correctly.
can you go over 100% because of dedupe ?
flyingparchment
you can use the extra space, but if df is showing that, that seems like an accounting bug
Exaltia
the lasest stable opensolaris is still 2009.06?
alanc
yes
[lewellyn]
yup
Exaltia
thanks
alanc
will be until March when 2010.03 is released
[lewellyn]
or thereabouts ;)
Exaltia
so, no security patch until that?
[lewellyn]
that's about the summary, there. unless you pay for support or track the development builds
ranks
flyingparchment: so is this a reported bug in snv_128a ?
e^ipi
Exaltia: in the support repo perhaps
[lewellyn]
i've also verified the dns (A and PTR) for the problematic host/ip :P
alanc
lots of security fixes in the support repo, and in /dev
[lewellyn]
it's stevel!
Exaltia
thanks
[lewellyn]
ok. so i guess i'll have to assume that i can't do what i want over nfs and have to copy it all locally :P
nachox
[lewellyn], install fuse and use sshfs? :)
[lewellyn]
nachox: that's not a helpful answer :P
(Action) decides that he's hating nfs again
i've got a long-lived love|hate affair with nfs ;)
ranks
So, do I need to report a bug with dedupe ? Is it a known bug ? Or am I just not understanding how dedupe works ?
nachox
openafs
[lewellyn]
nachox: hey. i'm the one who offers almost-plausible answers around here ;)
(Action) serves the files over tftp
nachox
[lewellyn], nonsense, i got my helpful user of the month badge last night
Sp0tter
i need this to work
[lewellyn]
someone jumped the gun then. you have 3 more weeks to fu*k up :)
Sp0tter: i missed it. is this hardware on the hcl?
nachox
hahaha
Sp0tter
(Action) stares at a bottle of pills and then looks over at his .357 mag :(
[lewellyn]: Trying to get jmicron 363 controllers to work
just bought two knew ones pcie to replace this junky pci one ihad
[lewellyn]
Sp0tter: you haven't seen enough of my moaning. your problem isn't as bad as what i deal with weekly ;)
jmicron is craptastic
i'd not use it for anything that needed high availability
Sp0tter
the installer sees the controller , says the driver is attached, and says its perfect
but it can't see the drives attached to it
[lewellyn]
where high-availability is more than storing your porn stash
nachox
haha
Sp0tter
be nice
nachox
Sp0tter, http://opensolaris.org/jive/thread.jspa?messageID=376370
that thread is about your card and shows the exact same behaviour
Sp0tter
yea
i've read it a hundred times
and tried both flashes they list there
even though they are clearly mistaken
[lewellyn]
GODDAMMIT. no 48-bit lba in guests. that's lame :P
(Action) reattaches on scsi
paulf
Howdy
Anybody had any problems with zvol performance? ZFS filesystems are fine, but zvols are considerably slower for me.
Sp0tter
nachox: the "solution" from that thread is to update the controller bios so you can use un-raid mode... which mine came already updated and are in un-raid mode
miine
Sp0tter: does the cards bios screen offer an option to attach drives?
kokotier
my cifs server is keeping falling :(
Sp0tter
the bios is slick, it shows all the atched rives and their mode
and you can create a raid if you want
or disable raid
paulf
Currently running build 127, but I've seen the same behavior for quite a while
nachox
kokotier, you're using indiana 111b?
kokotier
118a
nachox
i did never have problems with b127 :)
[lewellyn]
cifs should be fine in 118
nachox
Sp0tter, did you see the same output in prtconf that the one shown in that thread?
kokotier
i am dling a file with utorrent (win7) on my z: drive (that is the opensolaris share)
[lewellyn]
ok. this isn't cool. solaris doesn't even see the virtual scsi adapter :(
Sp0tter
nachox: yes
[lewellyn]
kokotier: do you follow cifs-discuss?
there have been recent threads about windows 7
Sp0tter
no
i didnt
mine said AHCI and didn't have hte "raid" part
kokotier
lewellyn no
Sp0tter
and it had the right device code
kokotier
there is some isssue with win7?
[lewellyn]
kokotier: read the past few weeks of archives (low volume list) and post if you still have questions :)
Sp0tter
AHCI (classcode - 010601)
[lewellyn]
i don't worry much about windows 7 yet, so i've not paid much attention
i worry more about win2k than win7 :P
Sp0tter
nachox: i'm in the installer now, and it shows the controller just fine
it says the driver is installed, all settings look right, and everything is peachy,
just no drives
[lewellyn]
all i can think of is that i'm missing some service for nfs clients... hm.
kokotier
http://opensolaris.org/jive/forum.jspa?forumID=214
?
[lewellyn]
(Action) can't really click links atm
smrt: explain mailing lists
smrt
Mailing lists are a great way to be on top of (or better, involved in) the community. There are mailing lists for almost anything you can think of. See them all at http://mail.opensolaris.org/
[lewellyn]
that's where i'd look :)
ranks
Can anyone answer why zpool shows dedupe working, but zfs list doesn't reflect it ?
[lewellyn]
(Action) hasn't touched dedupe yet
nachox
Sp0tter, sorry, i do not know what to do, i'd mail drivers-discuss
TheBentZone
i'd try with one drive
Sp0tter
nachox, ok thanks for trying
AbeFroman
ranks: by design
Sp0tter
brb
miine
Sp0tter: are there any kernel warnings?
Sp0tter: http://bugs.opensolaris.org/view_bug.do?bug_id=6881249
ranks
AbeFroman: Then what good is dedupe if you cant use the space, because the filesystem doesn't see the gains ? Im sure I'm missing something and just dont understand, and would like to understand.
kokotier
[lewellyn]
ranks
AbeFroman: Can you go past when zfs says 0% available with dedupe ?
kokotier
when i restart the RGE interface all is ok
lattera
I have a cifs share mounted on a linux box
I notice that I can't run programs that are stored on that cifs sahre
*share
is there any way to be able to run programs stored on a cifs share?
kokotier
yes
lattera
http://pastebin.com/d5cb868ab
kokotier
chown * -R
[lewellyn]
kokotier: so i'd blame the realtek nic :P
lattera
kokotier, that command makes no sense to me
kokotier
[lewellyn] it is working fine
with windows or linux
lattera
http://hub.opensolaris.org/bin/view/Project+smbfs/roadmap
found my answer, "No mmap or execute support"
[lewellyn]
dude. this makes no sense. :(
TheBentZone
lewellyn: you still playing whack a mole with nfs?
[lewellyn]
yeah
TheBentZone
solaris nfs server, clients are?
[lewellyn]
i've verified forward and reverse dns. and it looks to do the nfs stuff right in wireshark, up until the final LOOKUP where it gets an NFS4_ERRACCESS response
and nothing on the server's logs
TheBentZone
oh, have you tried mounting/remounting. I know it sounds stupid, but our oracle guy gave one of our admins so really bogus nfsopts, and xfer rate was in the sh*tter. I played with it for a bit, was trying something else, unmounted, and with sane options, we got our performance back
ranks
FYI, nosing around some forums, I noticed where the dedupe issue I am experincing is a known issue. they have several patches in place, but wont be fully resolved until snv_129
TheBentZone
ranks: so you probably dont want to write any more data ;-p
[lewellyn]
TheBentZone: i've tried rebooting the client a few times
TheBentZone
nfs3 or 4?
[lewellyn]
it's just being automounted
4
111b client, 117 server
TheBentZone
zfs share opts?