logo
IRC Archive / Freenode / #vbox / 2009 / December / 07 / 2
klaus-vb
are you using some unusual rdp client?
Azeotrope
klaus-vb: no, win XP's RDP client
klaus-vb
odd... haven't heard of issues with that since vbox 2.x times...
Azeotrope
I have 3.1.0.
klaus-vb: what do you suggest to do?
klaus-vb: if i do netstat -a | grep 4601 i get tcp 0 0 xxx-xxx-xxx-xxx.ro:4601 xxx-xxx-xxx-xxx.r:42435 TIME_WAIT
klaus-vb
I'd use wireshark to rule out that this is an iptables issue. if that's the case you automatically have a packet trace suitable for attaching to a vbox bug report...
Azeotrope
but i remember it worked once. the client connected with the VNC viewer because winXP RDP didn't work
klaus-vb: Ok. I started wireshark as root to listen on all interfaces with filter "port 4601" but I got nothing
please i need assistence
klaus-vb
Azeotrope: that shows that the problem is somewhere between your systems. it gets blocked somewhere
and that means it's totally off-topic here
if the traffic never reaches the vbox host then it can't possibly be the problem
Kira
God, I'm starting to suspect that VBox for Mac OS X has broken USB support in general.
klaus-vb
last time I checked God wasn't around in this channel ;)
Kira: what problems do you have?
AniWorks
(Action) greetz everyone!
Is any1 familier with export getting stuck on 100% on Windows 7 (x64-host) and using VBox 3.1.0?
puchu
hi
i run 2 xp guests on linux
and id like to share the clipboard between them .. it works but only for the first copied text ... after this the clipboard doesnt seem to get updated ... is there a way to fix this?
klaus-vb
AniWorks: no. and this sounds like the wrong place for such bug reports. it's unlikely that there's a quick workaround possible. the only thing you could try is disabling the export of the hard disk...
anli_
would be great if I could expose a physical hard drive to a vbox machine
So it can see both the virtual and the physical one
obfuscatr
puchu, i've had some success using synergy to transfer clipboards between VMs and disabling the feature in virtualbox. ymmv and it's a potential world of pain though.
puchu
synergy what is synergy?
guest to host works nice .. but host to host doesnt
Kira
klaus-vb: my Windows XP guest can't even recognise generic USB storage dongles or webcams.
klaus-vb
webcams can be tricky, but I haven't heard of issues with usb storage in quite some time
Kira
Ya, I figure it's absolutely abnormal.
klaus-vb
anli_: see manual, raw disk.
Kira
Does it have to do with 64-bit kernel mode of Mac OS X Snow Leopard?
klaus-vb
Kira: possibly. are you really using a 64bit kernel? that's for obvious reasons less tested than the 32bit case.
Kira
klaus-vb: yes, I specifically made it boot with the 64-bit kernel mode.
I even have a tool to tell me what kernel mode I'm in.
I would be really annoyed if all this is caused by the 64-bit kernel (again).
I'll test it again when I get the chance to reboot. It's not normal that the whole "USB Devices" menu item in the VBox toolbar is disabled (grayed out) to begin with.
kraut
is it possible to give a guest two cpus, but not to activate vt-x for that guest?
klaus-vb
kraut: no
kraut
damn
RHKratos
The vbox manual mentions rdp5.2 and rdp5.1, where 5.2 has the ability to supply your own CA certs and uses OpenSSL, how is that configured?
klaus-vb
kraut: what's the problem? vt-x enabled is a prereq for both guest smp and 64bit guests
kraut
klaus-vb: performance issue
klaus-vb
kraut: how severe?
is there a bug report for this?
spldart
Story leading to question: I downloaded the debian package for 3.1.0 and installed it on my debian lenny machine. Short of a quick apt-get -f install to fulfill dependencies I was golden. I then created a vm with 20 gig partition for xp and installed a legit copy of XP Pro Corp that I had slipstreamed all the service packs in. Things worked beautifully. I then added those 'additions' set up a share folder etc etc etc. I'm very excited and all
that. Problem is this. I then created another vm for Win 98se. Problem is I access a floppy .img of 98 startup floppy but boot hangs if I select 1) boot with cdrom support. I did go ahead and boot with 2) without cd rom support and successfully create a partition on 4 gig I set aside and formatted it. How can I get my 98se install stated? I assume 98 drivers on 98 floppy for cdrom's are to old. I don't know.
erstazi
Kira: grep vboxusers /etc/group | pastebinit -
spldart
s/stated/started
Kira
erstazi: sec
erstazi: It's empty.
klaus-vb
erstazi: this is on OSX (64bit)...
Kira
Hmm... did the 3.1.0 installer screw up?
mazenharake
Hi, I have a question about VirtualBox performance. I have tried 3 different Linux guests on my Vista Home host and they are all really slow. I don't suspect memory since I have played back and forth with it (Host: 3Gb, Guest 512Mb assigned currently). I also tried enabling/disabling various CPU settings ets. Nothing seems to work, everything is extreamly sluggish. Any ideas on how I can take this further? I have tried 3.1 and 2.1.4, both equally slow. T
erstazi
spldart: http://www.virtualbox.org/wiki/User_FAQ#Windows98guests
Kira: ah, nevermind about that command
spldart
Reading now erstazi :)
Thanks for the link.
mazenharake
I should mention I'm on a laptop as well if that makes any difference :)
klaus-vb
mazenharake: which guests...
erstazi
!pastebin_windows_config | mazenharake
mazenharake: pastebin (eg http://pastebin.com) the contents of C:\Users\<YOURUSERNAME>\.VirtualBox\Machines\<VMNAME>\<VMNAME>.xml (Vista and newer) or C:\Documents and Settings\<YOURUSERNAME>\.VirtualBox\Machines\<VMNAME>\<VMNAME>.xml (XP and older). Also, make sure to replace <YOURUSERNAME> and <VMNAME> with the appropriate name.
mazenharake
Ubuntu (9.x something) Suse 11.2 and was going for slackware but it didn't even start
spldart
Meh... Doesn't seem to cover my problem at all :(
mazenharake
so just count 2 guests then :)
spldart
My problem boils down to 'cannot get cdrom support from boot floppy .img so cannot initiate the install from the cdrom.
RHKratos
spldart: why not boot from the cdrom then?
mazenharake
erstazi; yeah probably I screwed up by removing everything before I thought of the idea of getting help on IRC :) I'm currently downloading gentoo see if it makes any diff
spldart
The virtualbox app just states 'this is not a bootable media' or some suck
heheh
s/suck/such
erstazi
mazenharake: can you read the first paragraph that I said to you?
spldart
The cd is fine.. I can stick a 98 boot floppy in an old k6-2 500 power rig and then initiate the install from the cdrom just fine.. I just can't do it in this virtualbox thingy
I guess I can follow one of those antique tutorials on how to take a non-bootable 98 cdrom and create a bootable one.
erstazi
spldart: you might need to change the boot order in virtualbox
spldart
I've tried unselecting all floppies and other images and just leave cdrom as the only boot device.
erstazi
!pastebin_linux_config | spldart
spldart: pastebin (eg http://pastebin.com) the contents of ~/.VirtualBox/Machines/<VMNAME>/<VMNAME>.xml (make sure to replace <VMNAME> with the appropriate case-sensitive name)
spldart
ic.. lemme boot that machine. I had worked on it last night till I pretty much passed out from fatigue last night
mazenharake
erstazi; you asked me to paste a bunch of xml files from the machine I set up. unfortunately I removed them already
thich was stupid of me I know
maybe I'll come back when I have something to paste ;)
erstazi
mazenharake: mind you, booting from a LiveCD to install is not a great performance measure
mazenharake
no that is not what happened. I installed both Suse and Ubuntu completely (despite the agony filled process)
I installed guest additions as well thinking it might help somewhat
but it didn't, this is why I'm asking if there are any tips in general for people complaining about slow performance (other then memory)
anli_
Ah, I managed to install linux on another hard drive using vbox actually
Now, if I restart the computer and boots up on that drive, will / still be /dev/sda1? :) Its a SATA drive
erstazi
mazenharake: this depends on a lot. you said this is a laptop that is the host.
mazenharake
yes that is correct
on the other hand, another laptop (the one I use for work) works fine, but it has vista professional (something)
I was hoping this would be a general problem but it seems I might be on my own since google and the forums don't really yield anything
erstazi
mazenharake: depends on your CPU model, your hard drive speed, how much ram you have (you have 3gb with 512mb for guest, which is fine), is VT-x enabled?, is PAE enabled?
mazenharake: is it 32bit guests? 64bit guests?
short_circuit
ok.. <this is spldart> I have a pastebin of the 98.xml... xp working fine and all I didn't pastebin it. http://pastebin.com/d3340f85c
erstazi
mazenharake: is your laptop plugged in when running these guests? if not, most modern laptops cut cpu freq in half
short_circuit
(Action) quests for coffee... getting ready for work still
mazenharake
I played around with VT-x and PAE, no change... Guests are 32 bit
laptop is plugged in
hmm... need to double check the 32bit part
Azeotrope
My Vbox machines have VRDP enabled on diffrent ports, host has rdp enabled and all the ports are allowed inbound but i still get the "remote computer has ended connections" as a client
mazenharake
but I'm almost 100% sure
:D
Azeotrope
I tried conencting from another VM, from another PC and from host
mazenharake
I'm off from work now so I need to go. Thank you erstazi for your time anyway mate
erstazi
no problem
anli_
wohoo! works like a charm!
I installed linux using vbox and now I booted up on that drive
I feared everything, but it just started
erstazi
(Action) hopes that anli_ read the warning in the raw disk section in the user manual
klaus-vb
Azeotrope: what makes me suspicious is that you didn't see rdp traffic in wireshark...
spldart
well poop :(
yopla
hello there. My kubuntu vbox guest works great but without openGL support.*
is there a way tou activate it ?
kriko
windows 2008 original: Sky[x]: pazi pri importu
eh sorry
JshWright
yopla: VBox version?
yopla
(My host is windows 7 64) vbox is 3.1
JshWright
yopla: is 3D acceleration enabled in the VM settings?
yopla
VboxAddition have installed correctly
samaelszafran
hello.
kriko
win 2008, latest vbox: http://imagebin.ca/view/f2S98Xx.html
yopla
yes with 128Mo
kriko
32 bit host
what could be the problem?
JshWright
yopla: crank that back down to 12mb or something, 128 is _way_ more than you need
the vram given to the guest is just system memory used to buffer the guest's display
yopla
OK I do this.
JshWright
yopla: does glxgears work in the guest?
yopla
yes it works
with no outpout
output erros
but game like supertuxkart doesn"t
and Composite (desktop effects) doesn't work too
I'm back
it still doesn't work with 12Mo
heres a Xorg.0.Log : (==) AIGLX enabled
(II) AIGLX: Screen 0 is not DRI2 capable
(EE) AIGLX error: vboxvideo does not export required DRI extension
(EE) AIGLX: reverting to software rendering
(II) AIGLX: Loaded and initialized /usr/lib/dri/swrast_dri.so
Azeotrope
klaus-vb: /quit
klaus-vb
Azeotrope: :)
Azeotrope
sorry
klaus-vb
if I were evil I'd have helped you to quit this channel :P
erstazi
haha
Azeotrope
i won't quit, i still got that issue with vrdp
klaus-vb
Azeotrope: does it work locally on the box? you might have set the vrdp listen address to 127.0.0.1 or some such...
I know that locally it means a different rdp client, but still
Azeotrope
i only set the port, not the bind address.. how do i do that?
klaus-vb
--vrdpaddress, as documented in the manual
if you don't set it, it allows any ip address
Azeotrope
klaus-vb: I didn't touched it
klaus-vb
so that shouldn't be it then. ah, something just came to my mind: you're not attempting to connect from two clients, do you?
by default only one client is allowed, and anyone coming later will get disconnected immediately
Azeotrope
klaus-vb: no, one client at a time
anli_
Can I use vbox machines in linus that I created in windows some year ago?
linux
Cant spell, sorry
klaus-vb
Azeotrope: better double check... it could be some forgotten session somewhere
Azeotrope
klaus-vb: how do i check that. i'll take it step by step
klaus-vb
netstat
gavacho
I've got an XP guest where the resolution isn't maximixed, and the full resolution available in the XP guest isn't the 1280x1024 that is available on the host. Am I missing something? I've got the Guest Additions installed
klaus-vb
gavacho: just switch to fullscreen mode
gavacho
klaus-vb: fullscreen mode only goes to 1280x904
klaus-vb: it's weird...
Azeotrope
klaus-vb: no, no ghost session
klaus-vb
gavacho: you don't mix up fullscreen and seamless?
gavacho
klaus-vb: no
klaus-vb: I don't have seamless enabled
User09
hey there.
i don't find the shared folder in vbox in my guest system. i expect, that the guest system did not load the vbox driver for shared folder. guest system == ubuntu 9.10
if i go to windows network he said that he's not able to mount it
gavacho
klaus-vb: http://pastebin.com/f715a07d3 <-- don't know if that is at all helpful
User09
sorry found solution @help
klaus-vb
gavacho: VBox.log would show the resize operations... is "Auto-resize Guest Display" enabled?
gavacho: the latter is in the gui "Machine" menu
ssd5
i am able to ping from linux to windows but not from windows to linux. destination host unreachable. am using ubuntu 9.10 server on virtualbox. i am using host only mode
klaus-vb
ssd5: just to double-check: you're saying that you're on windows host?
gavacho
klaus-vb: it is not enabled
ssd5
yes.
klaus-vb
gavacho: enable it. disabling means the GUI isn't allowed to tell the guest OS to change resolution
ssd5: sure it's not some odd windows firewall issue? it blocks ping by default
gavacho
klaus-vb: *whistling innocently*
klaus-vb: thanks man
ssd5
klaus-vb, actually I disabled windows firewall now and restarted the ubuntu networking service now I am getting "destination host unreachable on ubuntu too"
bsdnoob
Hello all !
Hello
klaus-vb
ssd5: did you misuse/misconfigure host only networking? it must be a separate network
Pete-J
Hello i am installing FreeBSD as a quest operating system, and i am just wondering what's the defaut address to the DHCP server VirtualBox is using when using NAT
ssd5
actually on guest, I am using 2 adapters one is NAT and another is host only. I didn'e do any configuration all is default. just configured IP address.
FergatROn
Hi folks, I just installed the Linux host x86_64 RPM of VirtualBox and I'm running into a small issue. I can't find the directory anywhere on my computer. I found the ".VirtualBox" in my $HOME, but "locate -i virtualbox" doesn't show anything. I'm really trying to find "VBoxGuestAdditions.iso". Thanks
ssd5
so, is that NAT adapter is affecting
FergatROn
Ok, VERY odd. I found the directory... under "/usr/share/virtualbox", but why isn't "locate -i virtualbox" finding it?
klaus-vb
ssd5: what are you pinging?
Pete-J: dhcp server (and gateway) is 10.0.2.2, VM IP address is 10.0.2.15
FergatROn: because the index used by locate hasn't been updated yet
FergatROn
klaus-vb, oh... is there a way I can invoke that?
RHKratos
The vbox manual mentions rdp5.2 and rdp5.1, where 5.2 has the ability to supply your own CA certs and uses OpenSSL, how is that configured?
ssd5
I am pinging host 172.140.4.122 from guest. ok see, when I ifdown that host only adapter then it is pinging from guest from NAT adapter.