logo
IRC Archive / Oftc / #debian / 2010 / June / 01 / 4
jordanm
sloosh: care to elaborate? (such as pasting the error)
!bat
dpkg
In order for us to troubleshoot your problem with apt-get, aptitude or dselect we need the following information: The complete output of your apt-get/aptitude/dselect run (including the command you used); the output from apt-cache policy PKG1 PKG2...; for the relevant packages and "apt-cache policy". Use http://paste.debian.net/ to provide us with this information. Also ask me about <localized errors>.
themill
ouch
see if you can find/download libc6_*.deb and then from outside the chroot, "dpkg -x /path/to/libc6*.deb /path/to/the/install"
cesurasean
what is the package name for inetd?
locklace
cesurasean: aptitude search inetd
Ss
fu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother defu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother defu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother defu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother defu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother de fu*k you mother defu*k you mother
carnage
hey, i'm trying to do this usb install again, i setup the usb stick exactly like it says in the manual (ch4s03) and i'm still getting an error when it goes searching for the cdrom which appears to be mounted from /dev/loop0 on /cdrom according to df
the df output also has this line in it though inbetween the tempfs and /dev/loop0 lines: df: /hd-media: Input/output error
which is, i assume, why i get a cdrom-retriever: error: Unable to find 'pool/main/l/lvm2/lvm2-udeb-2.02.39-7_i386.udeb'. error
because when i try to go looking for that file in the emergency console i get input/output errors from ls
and the two errors in the debug screen are: kernel isofs: unable to reade i-node block
and an anna warning package retrieval failed
XayOn
carnage: looks like a broken iso for me.
carnage
damn
i don't really want to download another one of those
so big
jordanm
its only 150mb
carnage
this one is 650 or so
jordanm
you can't use that for USB install
carnage
really? the guide says you can
jordanm
only the business card or netinst CDs iirc, if you are following the official guide
!ig
dpkg
The Debian Installation Guide for Lenny (5.0.4) can be found at http://www.debian.org/releases/lenny/installmanual . See also <errata> and <installer firmware>.
carnage
If you used an hd-media image, you should now copy a Debian ISO image (businesscard, netinst or full CD image; be sure to select one that fits) onto the stick.
the only other thing i can think of is a mismatch between the installer and the iso... i guess that's what you mean too eh... it also says here: The installation image and the CD image must be based on the same release of debian-installer.
jordanm
carnage: "After that, mount the USB memory stick (mount /dev/sdX /mnt), which will now have a FAT filesystem on it, and copy a Debian netinst or businesscard ISO image to it. Unmount the stick (umount /mnt) and you are done."
carnage
i'm wondering how i'd determine if they are the same
it says multiple times in the document that it can also use a full cd image
jordanm
the guide seems to contradict itself. I had always thought it was netinst or businesscard only, perhaps you should try just to see
carnage
alright, i will
what's the difference between businesscard and netinstall anyway?
all i really need is the base system and wifi support i guess
jordanm
carnage: sorry, I see now, you can only use the full cd if you follow "the flexible way" instead of "the easy way"
carnage
yeah, i did 'the flexible way'
jordanm
carnage: the netinst contains everything needed to install a base system. buisnesscard only includes the installer
carnage
but i'm thinking i still might try the business card or the netinst seeing as how i'm not sure what else to try next :p
alright, netinst it is
astronut
audio works on my system normally, but after creating a new user, adding them to the audio group and copying over my .asoundrc, this user gets "alsa-lib: pcm_dmix.c:977:(snd_pcm_dmix_open) unable to create IPC semaphore"
lsof shows there don't seem to be any handles...any pointers
Objection
Hello, I am currently using Debian Squeeze 64bit. I am wondering whether I should use the 2.6.32-trunk-amd64 or 2.6.32-3-amd64 kernel?
craigevil
Objection: 2.6.32-3-amd64 , the trunk kernels had issues
Objection
craigevil, Ah ok thanks.
astronut
ok, it just seemd to have resolved itself...
abraxus
hi
Objection
Bye
deavid
i'm having several problems with my 1st hard drive: at firts it seems to work perfectly, it runs all the OS... but after time, the system gets frozen for minutes, after that seems to work. Several times I/O error gets printed onto tty0...
petemc
deavid: check dmesg/syslog/messages
deavid
i believed that I have to change my hard disk, but there is something bizarre: Whenever I check for bad blocks, I cant find any
from a liveCD the drive seems to work
petemc
if the drive supports it you could try smartmontools
valdyn
id rather believe badblocks than smartmontools
koollman
I wouldn't. they don't test the same things
deavid
there is something in messages
ryan22
is the drive making weird griding noises?
valdyn
deavid: are you sure that those io errors are even related to the harddisk?
deavid
no
valdyn: the I/O errors points to sda, so yes
but i'm not sure if the problem it's really the hard drive
ryan22
it could be ram too
valdyn
i get those from an overheating southbridge on an usb disk
( -> doesnt need to be disk related )
deavid
seems overheating too
because it gets worse when its hot
valdyn
and that southbridge is broken by design, not because my case is venilated badly
deavid
this is a part of messages log: http://pastebin.com/45eZ7S9S
after "16:46:26" i had to reboot, the system was inusable
i'm running kde4, and the KDE button was lost, the desktop unresposive, etc..
ryan22
you could try laptop-mode-tools to tweak the hd usage
to reduce the hd accesses
valdyn
deavid: i would open the case and rerun the tests: sometimes thats enough to remove any heat problem
deavid
valdyn: the case is already open, and the test were done with the case closed first and later done again opened
valdyn
deavid: I see
deavid
the results are very similar, probably it gives an extra bit of time before it gets frozen
valdyn
M/B Temp: +63.0°C vs CPU Temp: +46.0°C
deavid: can be alot of issues, broken psu for one, thats hard to diagnose
ryan22
deavid: proably your best option is regulating hd accessing via laptop-mode-tools
at least until you can fix the hardware
deavid
ryan22: thanks for the hint, i want to try it now
the config file is very well commented, just make sure you set it to take effect if your computer is connected via ac
stuckey
hi
how do I get chinese fonts?
grummund
Hi, anyone have an idea how to redirect serial port comms to a *listening* tcp socket on the same machine?
(Action) is considering netcat but wonders what else...
deavid
it ocurred again: http://pastebin.com/x53r7trj i have to reboot now :-(
ryan22
deavid: try a memtest too
amphi
deavid: traumatic indeed ;)
ryan22
deavid: ive had i/o problems that appeared to be caused by the hd, but were really cause by mismatched ram
the mobo was just really picky :P
mjt
mismatched?
ryan22
mjt: i used a 533 mhz ram stick in a atom/ion mobo that required a 800 mhz ram
the ion mobos are REALLY picky about ram speed and voltage
mjt
all sane mobos will read the eeprom on the module and set up speed accordingly
but it is a bit more tricker if you try dual-channel config with different modules
petemc
grummund: socat
mjt
but ok, i see
ryan22
mjt: this was signle channel. its cause the graphics chip has strict requirements. the system would boot fine, but video wouldnt play
ions boards are a pain
mjt
it's difficult to find non-800MHz modules nowadays, too :)
ryan22
if you can, a 512 MB 533 mhz stick is $13
ya i cheaped out (it was kingston)
mjt
i tried to find a 512Mb one for my diskless x terminal (also on atom). Ended up buying 2Gb 800MGz to replace an 1Gb 533MHz in laptop ;)
ryan22
mjt: im still disappointed that ram has actually gone up in price over the last 2 years
carles
hi, is this the right place to ask a question about the local host name in Debian 5?
mjt
yes carles
carles
great, I have checked everything online and couldnt find an answer: I have set my local host name in /etc/hosts and /etc/hostname
I have checked that /etc/nsswitch.conf uses hosts: files dns
but still, host can't resolve my hostname
so my hostname is zonalo
ping zonalo works fine
but host zonalo returns nxdomain
petemc
host checks dns
mjt
actually not only dns
but generally dns does not deal with bare names without dots
petemc
man host gives -- host - DNS lookup utility
mjt
ok, i stand corrected. there's /etc/host.conf to control that somewhat
petemc: see order in host.conf. i'm not sure if host utility uses that conffile.
carles
done that
koollman
carles: hosts make a dns check. it wouldn't check what you are trying to verify
carles
order hosts, bind
koollman
getent hosts yourhost
would be the easiest way I can think of
carles
so hosts doesn't use /etc/hosts at all?
getent works fine: 127.0.1.1 zonalo zonalo.local zonalo.localdomain
but host doesn't
koollman
sure.
as I said, host make a dns request. it would be only the 'bind' part of the configuration. it will not read /etc/hosts
mjt
s/bind/dns/ for nsswitch.conf
koollman
getent will do the request as the OS does. reading the config, using the proper calls, and all
carles
and hosts will go directly to a DNS server then?
koollman
yes
carles
skipping the local conf files?
ok
mjt: my nsswitch.conf:
hosts: files dns
mjt
skipping local /etc/hosts, not local conf files.
koollman
well, different files.
carles
ok, understood
koollman
the 'host' tool will just read /etc/resolv.conf :)
carles
which is why I see a dns request that fails, since my dns server doesn't know about my hostname
and why the program I am trying to run is failing, because it must use a dns request directly
instead of doing whatever ping is doing, which uses /etc/hosts
mjt
which program it is?
carles
rabbitmq
Error: unable to connect to node rabbit@zonalo: nodedown
I assume they're doing a dns lookup for zonalo instead of using gethostbyname() (which I assume reads /etc/hosts)
nawaf
hello
mjt
i'm not sure if it uses dns directly. there's no need to, unless, well, unless it us using something more than A/PTR records or wants to resolve many names asyncronously
nawaf
anybody is here
how are u
carles
that is what is puzzling me actually, why would they use dns directly
locklace
nawaf: lots of debian users in saudi arabia?
mjt
carles: i you can try using strace - quite good debugging tool
heh.
carles
mjt: thanks, I'll give that a try
koollman: thanks for your help
mjt
especially look at ECONNREFUSED errors in strace output - my wild guess is that your server isn't running...
carles
mjt: ok, will check that
debacle
hi all, can anyone help me with backport ? I'm trying to install kernel 2.6.32 ... but i got this errors http://debian.pastebin.com/M8uhiQu1
m42
debacle, maybe trying to install udev also will solve that issue....
themill
debacle: install the "linux-image-amd64" package from bpo instead (it will install the bpo.3 kernel not the bpo.4 kernel)
deavid
ryan22: thanks! now with that the problem almost dissapered... there remains something, when it tries to save syslog entries and sync. but there is something good: the system doesn't freeze :-D :-D
ryan22
lol no prob
it also makes your system much quieter
as the hd is usually the noisiest thing in the computer nowadays
koollman
,9
debacle
themill: i got this error (quite the same) http://debian.pastebin.com/yujdjfVr
themill
debacle: you probably want to get rid of linux-base
debacle
themill: i've used this command aptitude -t lenny-backports reinstall linux-image-amd64 is it ok ?
themill
debacle: aptitude -t lenny-backports reinstall linux-image-amd64 linux-base_
(the _ at the end is deliberate)
jordanm
(Action) must have missed _ in the manual
debacle
themill: it seems to work !
themill
\o/
jordanm: that is actually in the manual ;) much of aptitude's power isn't, but that is!
nima_
hi, i install xfce distro on my lenovo netbook s10-3 when i right click on desktop xfdesltop cpu usage = 100% for 15 sec or more what i can for fix this prob?
hi, i install xfce distro on my lenovo netbook s10-3 when i right click on desktop xfdesktop cpu usage = 100% for 15 sec or more what i can for fix this prob?
ryan22
debian stable has an older version of xfce4 that may not be optimized
you can try backports
!backports
dpkg
[backport] a package from a newer Debian branch, compiled from source for an older branch to avoid dependency and ABI complications. http://www.debian.org/doc/manuals/reference/ch02.en.html (2.7.4 and 2.7.10), http://backports.org/ . Ask me about <backports.org> and <backport caveat>. See also <simple sid backport>.
allyourbass
nima, how much memory do you have? is there a lot of HDD activity as well?
jordanm
I still use the older packages just fine...
nima_
allyourbass, 1 GB of ram
jordanm
(Action) debated upgrading xfce4 to backports but did not because of the machine being in production
ryan22
jordanm: they dont have power manager. which makes it quite useless on a laptop
jordanm
nima_: what version of debian?
ryan22: ah. luckily doesn't effect me
nima_
jordanm, debian GNU/Linux 2.6.32
jordanm
nima_: alright, so now its narrowed down to 3 versions...
!version
dpkg
Kernel: uname -r. Debian: cat /etc/debian_version. and: dpkg -l libc6 | tail -n 1. Package: dpkg -l _pkgname_. Miscellaneous: try --version on the command. check /etc/apt/sources.list; run apt-cache policy <packagename>, or lsb_release -a, or cat /proc/version. Do cat /etc/{*version*,*release*,*issue*} which should grab almost all distributions.
nima_
jordanm, squeez
jordanm
nima_: so essentially opening up the menu is slow and very CPU intensive?
nima_
jordanm, i use top command in terminal and show me fxdesktop cpu usage = 100 % for 15 sec and more and every think hang when xfdesktop cpu usage=100%
ryan22
ya try upgrading xfce4